package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\'(.+?)'\]`)
var str = `['ABC']['ABC.5']['ABC.5.1']`
var substitution = "['$1']\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}