import Foundation
let pattern = #"\[\'(.+?)'\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"['ABC']['ABC.5']['ABC.5.1']"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"['$1']\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)