const regex = /\[\'(.+?)'\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\\'(.+?)\'\\]', 'gm')
const str = `['ABC']['ABC.5']['ABC.5.1']`;
const subst = `['$1']\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);