#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[\'(.+?)'\]"
Local $sString = "['ABC']['ABC.5']['ABC.5.1']"
Local $sSubst = "['$1']\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)