using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\'(.+?)'\]";
string substitution = @"['$1']\n";
string input = @"['ABC']['ABC.5']['ABC.5.1']";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}