using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\()(?<!eq )'(?!\)|\Z)";
string substitution = @"''";
string input = @"('hel'lo') eq 'some 'variable he're
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}