const regex = new RegExp('(?<!\\()(?<!eq )\\'(?!\\)|\\Z)', 'gm')
const str = `('hel'lo') eq 'some 'variable he're
`;
const subst = `''`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);