re = /(?<!\()(?<!eq )'(?!\)|\Z)/m
str = '(\'hel\'lo\') eq \'some \'variable he\'re
'
subst = '\'\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result