use strict;
my $str = '(\'hel\'lo\') eq \'some \'variable he\'re
';
my $regex = qr/(?<!\()(?<!eq )'(?!\)|\Z)/mp;
my $subst = '\'\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";