import Foundation
let pattern = #"(?<!\()(?<!eq )'(?!\)|\Z)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
('hel'lo') eq 'some 'variable he're
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"''"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)