#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\s+\\\[\s*(?P<brace_bloc>.*?)\s*\\\]\s+"
Local $sString = "foo \[ \left\\{" & @CRLF & _
"\begin{array}{cl}3=&1 + 2\\4=&2 + 2\end{array} " & @CRLF & _
"\right. " & @CRLF & _
"\]" & @CRLF & _
"bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")