const regex = new RegExp('\\s+\\\\\\[\\s*(?P<brace_bloc>.*?)\\s*\\\\\\]\\s+', 'gms')
const str = `foo \\[ \\left\\\\{
\\begin{array}{cl}3=&1 + 2\\\\4=&2 + 2\\end{array}
\\right.
\\]
bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}