import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+\\\\\\[\\s*(?P<brace_bloc>.*?)\\s*\\\\\\]\\s+";
final String string = "foo \\[ \\left\\\\{\n"
+ "\\begin{array}{cl}3=&1 + 2\\\\4=&2 + 2\\end{array} \n"
+ "\\right. \n"
+ "\\]\n"
+ "bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}