$re = '/\s+\\\\\[\s*(?P<brace_bloc>.*?)\s*\\\\\]\s+/ms';
$str = 'foo \\[ \\left\\\\{
\\begin{array}{cl}3=&1 + 2\\\\4=&2 + 2\\end{array}
\\right.
\\]
bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);