import re
regex = re.compile(r"\s+\\\[\s*(?P<brace_bloc>.*?)\s*\\\]\s+", flags=re.MULTILINE | re.DOTALL)
test_str = ("foo \\[ \\left\\\\{\n"
"\\begin{array}{cl}3=&1 + 2\\\\4=&2 + 2\\end{array} \n"
"\\right. \n"
"\\]\n"
"bar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")