package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)\s+\\\[\s*(?P<brace_bloc>.*?)\s*\\\]\s+`)
var str = `foo \[ \left\\{
\begin{array}{cl}3=&1 + 2\\4=&2 + 2\end{array}
\right.
\]
bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}