#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "name="([a-zA-Z])(\w+)"
Local $sString = "name="Text""
Local $sSubst = "name="\U\1\L\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)