// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"name="([a-zA-Z])(\w+)"#).unwrap();
let string = "name=\"Text\"";
let substitution = "name=\"\\U\\1\\L\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}