const regex = /name="([a-zA-Z])(\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('name="([a-zA-Z])(\\w+)', 'g')
const str = `name="Text"`;
const subst = `name="\U\1\L\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);