re = /name="([a-zA-Z])(\w+)/
str = 'name="Text"'
subst = 'name="\\U\\1\\L\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result