import Foundation
let pattern = #"name="([a-zA-Z])(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"name="Text""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"name="\U\1\L\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)