#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bfun (?=(?:[^"]*"[^"]*")*[^"]*$)"
Local $sString = ""let's have fun !!"" & @CRLF & _
"" & @CRLF & _
"""" let's have fun for "string" """" & @CRLF & _
"" & @CRLF & _
"let abfun = true" & @CRLF & _
"let funab = true" & @CRLF & _
"let afunb = true" & @CRLF & _
"" & @CRLF & _
"let f = fun a -> fun b -> a + b" & @CRLF & _
"" & @CRLF & _
"let g = 1 |> (fun a -> a + 1)" & @CRLF & _
"" & @CRLF & _
"let data = [fun a -> a + 1]" & @CRLF & _
"" & @CRLF & _
"// fun a -> a" & @CRLF & _
"" & @CRLF & _
"(*" & @CRLF & _
" fun a -> a" & @CRLF & _
"*)" & @CRLF & _
"" & @CRLF & _
"fun " & @CRLF & _
"" & @CRLF & _
"fun " & @CRLF & _
"" & @CRLF & _
"fun" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")