$re = '/\bfun (?=(?:[^"]*"[^"]*")*[^"]*$)/';
$str = '"let\'s have fun !!"
""" let\'s have fun for "string" """
let abfun = true
let funab = true
let afunb = true
let f = fun a -> fun b -> a + b
let g = 1 |> (fun a -> a + 1)
let data = [fun a -> a + 1]
// fun a -> a
(*
fun a -> a
*)
fun
fun
fun
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);