using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bfun (?=(?:[^""]*""[^""]*"")*[^""]*$)";
string input = @"""let's have fun !!""
"""" let's have fun for ""string"" """"
let abfun = true
let funab = true
let afunb = true
let f = fun a -> fun b -> a + b
let g = 1 |> (fun a -> a + 1)
let data = [fun a -> a + 1]
// fun a -> a
(*
fun a -> a
*)
fun
fun
fun
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}