import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bfun (?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)";
final String string = "\"let's have fun !!\"\n\n"
+ "\"\"\" let's have fun for \"string\" \"\"\"\n\n"
+ "let abfun = true\n"
+ "let funab = true\n"
+ "let afunb = true\n\n"
+ "let f = fun a -> fun b -> a + b\n\n"
+ "let g = 1 |> (fun a -> a + 1)\n\n"
+ "let data = [fun a -> a + 1]\n\n"
+ "// fun a -> a\n\n"
+ "(*\n"
+ " fun a -> a\n"
+ "*)\n\n"
+ "fun \n\n"
+ "fun \n\n"
+ "fun\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}