import Foundation
let pattern = #"\bfun (?=(?:[^"]*"[^"]*")*[^"]*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"let's have fun !!"
""" let's have fun for "string" """
let abfun = true
let funab = true
let afunb = true
let f = fun a -> fun b -> a + b
let g = 1 |> (fun a -> a + 1)
let data = [fun a -> a + 1]
// fun a -> a
(*
fun a -> a
*)
fun
fun
fun
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)