const regex = /\bfun (?=(?:[^"]*"[^"]*")*[^"]*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bfun (?=(?:[^"]*"[^"]*")*[^"]*$)', 'g')
const str = `"let's have fun !!"
""" let's have fun for "string" """
let abfun = true
let funab = true
let afunb = true
let f = fun a -> fun b -> a + b
let g = 1 |> (fun a -> a + 1)
let data = [fun a -> a + 1]
// fun a -> a
(*
fun a -> a
*)
fun
fun
fun
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}