#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+)\s\((\d+),(\d+)\)\s(\w+):\s(.+)$"
Local $sString = "Mad Pascal Compiler version 1.6.6 [2021/06/08] for 6502" & @CRLF & _
"Compiling kret.pas" & @CRLF & _
"kret.pas (19,5) Error: Syntax error, ';' expected but 'identifier' found"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")