const regex = /^(.+)\s\((\d+),(\d+)\)\s(\w+):\s(.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+)\\s\\((\\d+),(\\d+)\\)\\s(\\w+):\\s(.+)$', 'gm')
const str = `Mad Pascal Compiler version 1.6.6 [2021/06/08] for 6502
Compiling kret.pas
kret.pas (19,5) Error: Syntax error, ';' expected but 'identifier' found`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}