$re = '/^(.+)\s\((\d+),(\d+)\)\s(\w+):\s(.+)$/m';
$str = 'Mad Pascal Compiler version 1.6.6 [2021/06/08] for 6502
Compiling kret.pas
kret.pas (19,5) Error: Syntax error, \';\' expected but \'identifier\' found';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);