package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+)\s\((\d+),(\d+)\)\s(\w+):\s(.+)$`)
var str = `Mad Pascal Compiler version 1.6.6 [2021/06/08] for 6502
Compiling kret.pas
kret.pas (19,5) Error: Syntax error, ';' expected but 'identifier' found`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}