re = /^(.+)\s\((\d+),(\d+)\)\s(\w+):\s(.+)$/m
str = 'Mad Pascal Compiler version 1.6.6 [2021/06/08] for 6502
Compiling kret.pas
kret.pas (19,5) Error: Syntax error, \';\' expected but \'identifier\' found'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end