import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+)\\s\\((\\d+),(\\d+)\\)\\s(\\w+):\\s(.+)$";
final String string = "Mad Pascal Compiler version 1.6.6 [2021/06/08] for 6502\n"
+ "Compiling kret.pas\n"
+ "kret.pas (19,5) Error: Syntax error, ';' expected but 'identifier' found";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}