#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<site>www\.[^ ]+)\s+(?<response_code>\d+)"
Local $sString = "02-Mar-2021 UDP Response Found Response Type: ABC" & @CRLF & _
"www.site1.com 404" & @CRLF & _
"www.site10.com 100" & @CRLF & _
"www.site4.com 400" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")