import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<site>www\\.[^ ]+)\\s+(?<response_code>\\d+)";
final String string = "02-Mar-2021 UDP Response Found Response Type: ABC\n"
+ "www.site1.com 404\n"
+ "www.site10.com 100\n"
+ "www.site4.com 400\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}