const regex = /(?<site>www\.[^ ]+)\s+(?<response_code>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<site>www\\.[^ ]+)\\s+(?<response_code>\\d+)', 'gm')
const str = `02-Mar-2021 UDP Response Found Response Type: ABC
www.site1.com 404
www.site10.com 100
www.site4.com 400
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}