import re
regex = re.compile(r"(?<site>www\.[^ ]+)\s+(?<response_code>\d+)", flags=re.MULTILINE)
test_str = ("02-Mar-2021 UDP Response Found Response Type: ABC\n"
"www.site1.com 404\n"
"www.site10.com 100\n"
"www.site4.com 400\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")