package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<site>www\.[^ ]+)\s+(?<response_code>\d+)`)
var str = `02-Mar-2021 UDP Response Found Response Type: ABC
www.site1.com 404
www.site10.com 100
www.site4.com 400
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}