re = /(?<site>www\.[^ ]+)\s+(?<response_code>\d+)/m
str = '02-Mar-2021 UDP Response Found Response Type: ABC
www.site1.com 404
www.site10.com 100
www.site4.com 400
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end