# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/L([0-9]*,[0-9]*)\b \KM\1//g;t' <<< "M329789,22223 L333539,22223 M333539,22223 L333539,24023 M333539,24023 L329789,24023 M329789,24023 L329789,22223"