import re
regex = re.compile(r"L([0-9]*,[0-9]*)\b \KM\1")
test_str = "M329789,22223 L333539,22223 M333539,22223 L333539,24023 M333539,24023 L329789,24023 M329789,24023 L329789,22223"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)