#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "L([0-9]*,[0-9]*)\b \KM\1"
Local $sString = "M329789,22223 L333539,22223 M333539,22223 L333539,24023 M333539,24023 L329789,24023 M329789,24023 L329789,22223"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)