$re = '/L([0-9]*,[0-9]*)\b \KM\1/';
$str = 'M329789,22223 L333539,22223 M333539,22223 L333539,24023 M333539,24023 L329789,24023 M329789,24023 L329789,22223';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;