using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"L([0-9]*,[0-9]*)\b \KM\1";
string substitution = @"";
string input = @"M329789,22223 L333539,22223 M333539,22223 L333539,24023 M333539,24023 L329789,24023 M329789,24023 L329789,22223";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}