use strict;
my $str = 'M329789,22223 L333539,22223 M333539,22223 L333539,24023 M333539,24023 L329789,24023 M329789,24023 L329789,22223';
my $regex = qr/L([0-9]*,[0-9]*)\b \KM\1/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";