using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{6}),(\d{7}),(\d{6})";
string substitution = @"'$1','$2','$3'";
string input = @"123412,5123513,312341";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}