import Foundation
let pattern = #"(\d{6}),(\d{7}),(\d{6})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"123412,5123513,312341"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'$1','$2','$3'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)