// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{6}),(\d{7}),(\d{6})").unwrap();
let string = "123412,5123513,312341";
let substitution = "'$1','$2','$3'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}