re = /(\d{6}),(\d{7}),(\d{6})/
str = '123412,5123513,312341'
subst = '\'$1\',\'$2\',\'$3\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result