import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\")[^\"]+?(?=\"(?:\\s*?,|\\s*?$))|(?<=(?:^|,)\\s*?)(?:[^,\"\\s][^,\"]*[^,\"\\s])|(?:[^,\"\\s])(?![^\"]*?\"(?:\\s*?,|\\s*?$))(?=\\s*?(?:,|$))";
final String string = "it, finds, values, in, comma, separated, lists\n"
+ "(it also matches new lines and any whitespace, hence the end-of-line highlight) \n"
+ "it, \"handles double quotes\"\n"
+ "it, \"handles, double, quotes, with, commas, in, them\"\n"
+ " it, ignores, trailing whitespaces \n"
+ "\" unless it's in quotes \"\n"
+ ",,,,,and,,,,,handles-??-weird.stuff,,,,,,?????\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}